Back to overview
Degraded
Bowser Gallery SSL issue
Mar 5, 2026 at 10:22pm UTC
Affected services
bowser.gallery
Resolved
Mar 6, 2026 at 9:17am UTC
Monitors have shown good results and now pictures are showing again on Discord as expected! Thanks for your patience!
Affected services
Updated
Mar 6, 2026 at 8:57am UTC
The issue has been identified and a fix is being deployed.
Affected services
Created
Mar 5, 2026 at 10:22pm UTC
Images coming from bowser.gallery doesn't embed. Investigating the issue.
The site is up and can be accessed normally.
Affected services